Not in the case of ASUS motherboards though, as the Taiwanese hardware manufacturer has released a dedicated software solution that can make the entire process a lot easier.

updating bios using asus-17updating bios using asus-24

Of course in my case it may have just been a faulty connection but whatever it's worth a try. Dhanushka_Liyanage posted the best working solution, but will require technical knowledge/expertise to perform the fix. And also CPU fan worked endlessly giving a hint that motherboard was working. I dismantled the laptop completely and separated motherboard from other components.

There are some good demos on how to open these machines on Youtube. Because I checked by disconnecting LCD connector and connected external monitor, It didn't work.

Isolated this chip by covering other electronic components by using alufoil with capton tapes. Heated GPU using hot air gun by monitoring the temperature. Needed to heat it up to 220deg celcius and maintain it for 1-2min.

If you don't have the technical expertise, I suggest you bring your laptop to an expert computer technician. reposting Dhanushka_Liyanage solution: "I had similar problem with Asus K43Jr model. HDD worked only for few seconds and HDD LED went off.

Would you like to answer one of these unanswered questions instead?

ASUS Win Flash provides owners of ASUS mainboards with a quick and simple way of updating the system BIOS software. I don't know what to do anymore, I tried everything: hold the power button, take out the hdd, take out the optical drive, switch the ram, verified all the connectors to mainboard, take out the bios battery, even reflow the gpu. There is two signs around it representing "locked" and "unlocked". Just be careful when opening the machine up, removing first the tabs by the RAM under the back cover. It turns on, the lights are on, only the light from hdd stays about 1 sec on after that it turns off, cooler doesn't turn on at all and the screen is black. There is plastic screw somwhere near the RAM slots. I then replaced the HDD and immediately the Windows process started and everything was back to normal. I don't know what to do anymore, I tried everything: hold the power button, take out the hdd, take out the optical drive, switch the ram, verified all the connectors to mainboard, take out the bios battery, even reflow the gpu. Hi fellas My name is Saeed I had the same problem last night. In BIOS, to load the default values ​​or go to System Administration and change to Enable LEGACY not to charge the Win8 image (also to add USB boot, watch videos on youtube). It turns on, the lights are on, only the light from hdd stays about 1 sec on after that it turns off, cooler doesn't turn on at all and the screen is black. When you held power button on, did u remove the battery? Then keep pressing Fn F5 simultaneously and hold, press the start button. They also have the possibility to enter the BIOS pressing the DEL button repeatedly immediately after starting. I turned mine off by holding the off button in for 2 minutes. This time it showed Windows updating , which took quite some time. HDD worked only for few seconds and HDD LED went off.